Подсистема Windows для Linux стала главной рабочей средой для моих инструментов веб-разработки при использовании Microsoft Windows. Там же использую Jekyll 4, который требует для работы версию Ruby 2.4 или старше, и устанавливается в подсистему Windows для Linux следующим образом.

Сначала следует установить свежую версию Ruby (на момент написания заметки текущая стабильная версия Ruby 2.6.5). Для этого подключается репозиторий BrightBox, содержащий оптимизированные версии Ruby для Ubuntu.

sudo apt-add-repository ppa:brightbox/ruby-ng
sudo apt-get update
sudo apt-get install ruby2.6 ruby2.6-dev build-essential dh-autoreconf

При необходимости обновляются установленные до этого gem’ы:

gem update

Теперь устанавливается сам Jekyll. Для этого выполняется команда:

gem install jekyll bundler

Установленная версия Jekyll проверяется так:

jekyll -v

Проверка установленных версий Ruby и Jekyll в подсистеме Windows для Linux

Процесс установки Jekyll 4 на этом завершён, можно приступать к работе с веб-сайтами.